[Update January 2017: now you can install the latest Skype version for Desktop v. 7.3 and it will work with Skyprivate plugin. Download from Skype.com or from your account]

Original FAQ:
The latest version of Skype 6.22 or Skype 7 is not yet supported by our Skyprivate plugin because some changes Skype did in their API (a feature we use to make the plugin work). To continue charging per minute for your calls use, we highly recommend you to use version 6.21 until future news from our side. 

In case you've made the update already, you can uninstall it and install the 6.21 version from:
link: http://www.skyprivate.com/download/SkypeSetupFull.exe or 
link: http://download.skype.com/msi/SkypeSetup_6.21.0.104.msi

We are investigating the issue and also waiting for Skype to push another update that fixes the API use and other 3rd parties use to communicate with Skype software. We will update this FAQ when we have news.
After installing, disable automatic updates in Skypehttps://support.skype.com/en/faq/FA12096/how-do-i-turn-off-automatic-updates-in-skype-for-windows-desktop
To help get Skype to fix this faster, please open a support ticket at Skype and tell them they need to get this fixed. That would be a great help: 
https://support.skype.com/en/support_selection_after_search